This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more hereX

System Requirements


System Requirements:
All courses contain PDFs, and some may contain videos. To use these materials you will need to ensure you have the following installed:
Please ensure that your computer is capable of installing these programmes before purchasing a course.
 
Browser information:
The globe system is optimised for the following browsers:
  • Internet Explorer 6.0 – 8.0
  • Mozilla Firefox 3.0 – 4.0
  • Safari 4.0 – 5.0

 


Our Sponsors/Partners

pne development